Service Web seems to be down

Major Incident Web
25 minutes

Update

Resolved

Service is back up.

March 7th, 2019 at 21:00 PDT
Issue

Our monitoring system has found out the service Web is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

March 7th, 2019 at 20:35 PDT