Service Web seems to be down

Major incident Web
1 hour, 13 minutes, 23 seconds

Updates

Resolved

Service is back up.

October 17, 2018 · 22:39 PDT
Issue

Our monitoring system has found out the service Web is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

October 17, 2018 · 21:26 PDT