Service Join seems to be down

Major Incident Join
2 minutes

Update

Resolved

Service is back up.

November 9th, 2018 at 08:51 PDT
Issue

Our monitoring system has found out the service Join is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 9th, 2018 at 08:49 PDT