Service Web seems to be down

Major Incident Web
31 minutes

Update

Resolved

Service is back up.

November 23th, 2018 at 10:01 PDT
Issue

Our monitoring system has found out the service Web is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 23th, 2018 at 09:30 PDT