Service Join seems to be down

Major Incident Join
23 minutes

Update

Resolved

Service is back up.

December 2th, 2018 at 12:33 PDT
Issue

Our monitoring system has found out the service Join is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

December 2th, 2018 at 12:10 PDT