Service Web seems to be down

Major Incident Web
2 minutes

Update

Resolved

Service is back up.

December 7th, 2018 at 02:32 PDT
Issue

Our monitoring system has found out the service Web is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

December 7th, 2018 at 02:30 PDT